WordPress и старые версии PHP, MySQL на Raspberry

В требованиях к WordPress рекомендован хостинг, который поддерживает:
— PHP версии 7 или выше
— MySQL версии 5.6 или выше ЛИБО MariaDB версии 10.0 или выше
— Протокол HTTPS
Сервер может работать и на старых версиях PHP и MySQL: PHP 5.2.4+ и MySQL 5.0+ , но так как их поддержка прекращена, то есть риск безопасности сайта. Домашний cервер Raspberry Ваша собственность, хостинг-провайдером являетесь сами, необходимо произвести проверку. Все делаем в командной строке:
Проверяем версию MySQL:
Проходим авторизацию mysql –u root –pпароль
При успешном входе увидим в строке
mysql>
Смотрим версию MySQL
select version();  
Для выхода необходимо ввести QUIT
Проверяем версию PHP:
Набираем в командной строке
php -v
Если мы видим старые версии PHP и MySQL, то принимаем меры к обновлению.
Протокол HTTPS желателен, подключение рассмотрено тут:  https://raznoe.su/server-na-raspberry-i-sertifikat-ssl/
Если используем HTTP, то ничего страшного в этом нет, огромное количество блогов используют протокол HTTP и это не сказалось на их работе.

Добавить комментарий

2 × 5 =